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1 Finally! POS for .NET 1.14 
The long overdue update to POS for .NET SDK has finally arrived. POS for .NET v1.14 release was a 
surprise since Microsoft never announced that they were working on an update. Unfortunately, the beta 
cycle was very short giving very little time to do significant testing, but the SDK delivers the basic 
elements that developers have been asking for: 
 

 Support for .NET Framework 4.x and 64-bit applications. The .NET Framework 2.0 requirement is 
no longer needed. 

 Installation consistent with POS for .NET 1.12. The SDK location doesn’t change. 

 Aligned with UnifiedPOS v1.14. 

 Builds on the OPOS service object support with 8 new devices. 
 
Best of all, the development process has not changed. The development processes discussed in the 
book, Professional's Guide to POS for .NET, are still the same. This paper services as an addendum to 
the book to cover POS for .NET v1.14 SDK. 
 
 

2 Creating an Application 
Although the process to create an application using the new SDK is the same, you need to use Visual 
Studio 2012 or higher. Visual Studio 2013 will be used here to create a simple application that uses an 
MSR (Magnetic Strip Reader). A Magtek MSR will be the MSR POS device.  The MagTek’s POS for .NET 
1.12 service object will be used for testing the application. In the future, the 1.14 service object should be 
used for a real product when available, but until then MagTek’s 1.12 version will have to do.  The first 
steps are to make sure that the Service Objects or OPOS drivers are installed and successfully work with 
the SDK’s TestApp.exe. Once the Service Object or OPOS driver is in place, you can create the 
application. 
 

2.1 Part 1 – Create the Application 

First step is to create the project. 
 

1. Open Visual Studio 2013. 
2. From the menu, select File->New->Project. The New Project dialog appears. 
3. From the templates, select Visual C#->Windows. 
4. The click on Windows Form Application. 
5. Name the project MSR114_CS. 
6. Click OK. 

 

http://www.annabooks.com/Book_PGPOS.html
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7. Adjust the size of Form1 to accommodate long numbers. 
8. On the form, add a TextBox control and two Labels with the following properties: 

 
TextBox: 

Name: txtInput 
 

Label1: 
Name: lblMSRData 
Text: MSR data: 
Font: Arial, Regular, 12pt 

 
StatusStrip->Label: 

Name: TTStatus 
Text: Ready 
Font: Arial, Regular, 12pt 

 
9. Save the project. 

 

2.2 Part 2: Adding the POS for .NET Libraries and Code 

Next, we add the Microsoft.PointOfService.dll and the code for the MSR. 
 

1. From the menu, select Project->Add Reference. This will open the Add Reference dialog. 
2. Click on the Browse tab, and locate the Microsoft.PointOfService.dll found under c:\Program 

Files(x86)\Microsoft point of Service\SDK. 
3. Click on the OK button. 
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4. Open Form1.CS in code view. 
5. At the top of the code before the From1 class, add the imports: 

 
using Microsoft.PointOfService; 

 
6. After the Public Partial Class Form1, add the following: 

 
private PosExplorer myExplorer; 

private Msr myMsr; 

 
1. In the Form1() method, add the following code after the InitializeComponent() call: 

 
myExplorer = new PosExplorer(this); 

myExplorer.DeviceAddedEvent += new DeviceChangedEventHandler(myExplorer_DeviceAddedEvent); 

myExplorer.DeviceRemovedEvent += new DeviceChangedEventHandler(myExplorer_DeviceRemovedEvent); 

 

DeviceInfo device = myExplorer.GetDevice ("Msr"); 

 

if (device == null) 

{ 

TTStatus.Text = "Msr Not Found"; 

} 

else 

{ 

myMsr = (Msr)myExplorer.CreateInstance(device); 

myMsr.Open(); 

myMsr.Claim(1000); 

myMsr.DataEvent += new DataEventHandler(myMsr_DataEvent); 

myMsr.DeviceEnabled = true; 

myMsr.DataEventEnabled = true; 

myMsr.DecodeData = true; 

TTStatus.Text = "Found Msr - Ready"; 

} 

 
Notice that we are getting the Msr device by default and not using a logical name. Therefore, we will have 
to remove any other Msr service objects that may be in the system.   
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After you enter += for each event, hit Tab twice so Visual Studio can automatically generate the event 
callback. 
 

2. Save the project. 
3. Add the following code to the myExplorer_DeviceAddedEvent subroutine: 

 
if (e.Device.Type == "Msr") 

{ 

myMsr = (Msr)myExplorer.CreateInstance(e.Device); 

TTStatus.Text = "Found Msr - Ready"; 

myMsr.Open(); 

myMsr.Claim(1000); 

myMsr.DataEvent += new DataEventHandler(myMsr_DataEvent); 

myMsr.DeviceEnabled = true; 

myMsr.DataEventEnabled = true; 

myMsr.DecodeData = true;  

} 

 
4. Save the project. 
5. Add the following code to the myExplorer_DeviceRemovedEvent: 

 
if (e.Device.Type == "Msr") 

{ 

myMsr.DataEventEnabled = false; 

myMsr.DeviceEnabled = false; 

myMsr.Release(); 

myMsr.Close(); 

TTStatus.Text = "Found Msr - removed"; 

} 

 
6. Save the project 
7. Add the following code to the myMSR_DataEvent subroutine 

 
ASCIIEncoding myEncoding = new ASCIIEncoding(); 

txtInput.Text = myEncoding.GetString(myMsr.Track2Data); 

myMsr.DataEventEnabled = true; 

 
The last step is to re-enable data events so other Msr swipes can be made. 
 

8. Save the project. 
 

2.3 Part 3: Build and Test 

The project can now be tested, but first we need to isolate the MSR being used. The first steps are to 
move the example service object and the simulator service object to another location. We can then test 
the application. 
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1. Open File Explorer. 
2. Go to the C:\Program Files (x86)\Microsoft Point Of Service\SDK\Samples\Simulator Service 

Objects directory. 
3. Cut and paste Microsoft.PointOfService.DeviceSimulators.dll to C:\Program Files (x86)\Microsoft 

Point Of Service\SDK\Samples 
4. If you are using the Example service Object from the SDK, skip to step 6. Go to C:\Program Files 

(x86)\Microsoft Point Of Service\SDK\Samples\Example Service Objects. 
5. Cut and paste Microsoft.PointOfService.ExampleServiceObjects.dll to C:\Program Files 

(x86)\Microsoft Point Of Service\SDK\Samples. 
 

 
 
The above steps remove the extra virtual Msr’s that are not needed for the application. The program will 
select the first Msr as the default, and we want it to be the actual physical Msr, rather than the simulator 
service object. 
 

6. Make sure the MSR is not attached to the system. 
7. In Visual Studio, run the application. 
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8. Connect the MSR. 
 

 
 

9. Swipe a card to read the data. 
 

 
 

10. Unplug the MSR. 
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11. Close the application. 
 
 

3 Upgrade Applications to .NET Framework 4.x 
For those of you who have built applications with an older Visual Studio version, updating the POS for 
.NET portion of the project requires a few changes. These steps are only for POS for .NET. If you are 
using other libraries in your project, you might have to upgrade those as well. 
 

3.1 Updating A C# Application 

Using an example from the book, EX31_Bar_Code_CS, here are the steps to update a POS for .NET 
v1.12 project to POS for .NET v1.14. 
 

1. Download and extract the Book Exercises for Professional's Guide to POS for .NET 
http://www.annabooks.com/Book_PGPOS.html. 

2. Open Visual Studio 2013. 
3. From the menu Select File->Open->Project/Solution. 
4. Locate and open EX31_bar_Code_CS. 
5. A dialog appears about trustworthy source, click OK to continue. 

 

 
 

6. Visual Studio 2013 will open the C# project without errors. Try building the application and you 
will see errors referencing the old assembly. 

 

http://www.annabooks.com/Book_PGPOS.html
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7. From the menu, select Project->EX31_Bar_Code_CS Properties. 
8. Change the Target Framework from 3.5 to 4.0. 
9. A dialog will appear asking if you really want to do this, click Yes. This is a simple application. If 

there were any APIs specific to .NET Framework 3.5, you will have to use the new ones for 4.0. 
 

 
 

10. In Solution Explorer, delete the reference for the old POS for .NET 1.12. 
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11. From the menu, select Project->Add Reference. This will open the Add Reference dialog. 
12. Click on the Browse tab, and locate the Microsoft.PointOfService.dll found under c:\Program 

Files(x86)\Microsoft point of Service\SDK. 
13. Click on the OK button. 
14. Save the project 
15. Try rebuilding the project, and this time it should succeed. 

 

 
 

3.2 Updating A VB.NET Application 

VB.NET conversion is a little different from C#. We will use the VB.NET version of the application above: 
EX31_Bar_Code. 
 

1. Open Visual Studio 2013. 
2. From the menu Select File->Open->Project/Solution. 
3. Locate and open EX31_bar_Code. 
4. If asked about a trusted source, click Ok. 
5. If you run the application, you will get an assembly error. 
6. From the menu, select Project->EX31_Bar_Code Properties. 
7. Change the Target Framework from 3.5 to 4.0. 
8. A dialog will appear asking if you really want to do this, click Yes. This is a simple application. If 

there were any APIs specific to .NET Framework 3.5, you will have to use the new ones for 4.0. 
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9. Click on the References tab, you will notice that Microsoft.PointOfService 1.14 is already 
referenced. 

 

 
 

10. Build the application again, and it should build successfully. 
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4 32bit versus 64bit Support 
POS for .NET 1.12 only supports 32-bit applications. POS for .NET 1.14 adds 64-bit support, but 64-bit 
support is a little tricky. All OPOS and Service Objects created with POS for .NET 1.12 are 32-bit. A 64-bit 
application cannot access a 32-bit OPOS or Service Object.  
 
For example, I recreated the book’s EX31_Bar_Code project from scratch using Visual Studio 2013 and 
POS for .NET 1.14. The bar code scanner is the Honeywell IT5600. The IT5600 POS for .NET 1.12 
Service Object was the latest from Honeywell. Building the application was clean, but when I ran the 
application, a run-time error appeared. 
 

 
 
The problem was that the project was set to run as “Any CPU” by default. On a 64-bit system the 
application runs in 64-bit mode. 
 

 
 
Since the Service Object is 32-bit, the application should be set to 32-bit. 
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After rebuilding, the application runs successfully. If you really want a 64-bit application, you’re going to 
be stuck in this case. The POS for .NET online documentation discusses the 32-bit vs. 64-bit issue and 
how to modify the registry for 32-bit OPOS drivers so that 64-bit applications can interact with a 32-bit 
OPOS driver via IPC and marshaling. There is nothing obvious or discussed on how to re-register Service 
Objects in this manner. You will have to wait until the POS device manufacturer releases a 64-bit Service 
Object or continue with 32-bit development, which brings us to the last topic on Service Objects. 
 
 

5 Service Objects and More 32-bit versus 64-bit 
To explore the 32-bit and 64-bit dynamic a little further and review service object development, I 
recreated the Avery Berkel 6710 scale service object from the book using POS for .NET 1.14 and Visual 
Studio 2013. I also updated the ScaleSOTest application to test the service object. The following sections 
report what was found: 
 

5.1 Information on Creating Service Objects in POS for .NET 1.14 

The steps to create service objects have not changed, but there are a few changes in filling out the code. 
When you enter “Inherits ScaleBasic” class, there are some addition capabilities and features added to 
meet the changes in the UnifiedPOS 1.14 specification. For the scale service object, there were some 
capabilities and subroutines added for pricing. Each service object is different. If you are a service object 
developer, you will have to be aware of these changes. Also, the SecurityAction items in AssembyInfo.vb 
file are no longer needed and can be removed: 
 
<Assembly: PermissionSet(SecurityAction.RequestMinimum, Name:="FullTrust")>  
<Assembly: SecurityPermission(SecurityAction.RequestMinimum, Execution:=True, 
ControlAppDomain:=True)>  
<Assembly: ReflectionPermission(SecurityAction.RequestMinimum)>  
 

5.2 Managing Service Objects in POS for .NET 1.14 

Managing service objects has not changed. POSDM.EXE and the WMI capabilities operate as before. It 
was a little concerning that POSDM and the WMI was not available in the beta, but it appears to be 
working as before. Any custom application used to manage service objects will have to be updated. We 
are working on an updated SOManager utility. 
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5.3 32-bit versus 64-bit Service Object Investigation 

With the test application and service object updated to POS for .NET 1.14 and .NET Framework 4.0, I 
tested to see what happens when the test application and service object are compiled to AnyCPU, x86, 
and x64. The test computer was running Windows 7 64-bit operating system. The table below shows the 
results: 
 

 Service Object 

A
p

p
li

c
a
ti

o
n

  AnyCPU x86 x64 

AnyCPU Yes No Yes 

x86 Yes Yes No 

x64 Yes No Yes 

 
When the service object is compiled as AnyCPU, any compiled version of the application will run. If the 
service object is compiled with x86, only the x86 application will run. The inverse happens when the 
service object is compiled to x64. The next logical test is to run the tests on a Windows 7 32-bit operating 
system, but I will leave this test to the reader. 
 


