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The Nios II is a 32-bit soft processor core for Intel FPGAs. The Nios II softcore processor is an IP 
block that comes with the Quartus Prime tools. The Nios II comes in two flavors Nios II/f (fast) and 
Nios II/e (economy). The Nios II/f is larger and takes up a few more Logical Elements in the chip, 
but it has MMU support for real-time operating system applications. Nios II/e is smaller with no 
MMU support. Nios II/f requires a license and the Nios II/e doesn’t. In this hands-on exercise, we 
will create a simple Nios II/f design and run a hello world application on the new processor. 
 
The Project Requirements: 
 

• Intel Quartus Prime Lite Edition V21.0 and Nios® II SBT for Eclipse already installed. 

• Intel® MAX® 10 - 10M08 Evaluation Kit and the schematic for the evaluation board are 
required. The schematic PDF file can be downloaded from the Intel FPGA website. 

• Intel FPGA Programming cable – USB Blaster II or EthernetBlaster II. The Intel® MAX® 
10 - 10M08 Evaluation Kit doesn’t have a built-in USB Blaster II on board. 

• Intel® Quartus® Prime Lite and Nios® II SBT for Eclipse Installation Instructions on 
Annabooks.com 

 
Note: There are equivalent MAX 10 development and evaluation boards available. These boards 
can also be used as the target, but you will have to adjust to the available features on the board. 
Please make sure that you have the board’s schematic files as these will be needed to identify pins. 
 
Windows was used as the host OS during the development of this paper, and there were problems 
running the development tools on Windows. Eclipse is the application development environment, 
which by itself is not a problem. The issue is that Linux commands are required to set up and build 
application projects. The Windows Subsystem for Linux has to be installed along with a Linux 
distribution such as Ubuntu. There were many little steps to getting all these items set up. Even 
after all the little steps to get Eclipse running were taken, applications would fail to build because 
“make” was not found. After a few searches and comparison tests with an Ubuntu setup were made, 
all the little steps necessary to get the software to build and run were worked out. Please see the 
article Intel® Quartus® Prime Lite and Nios® II SBT for Eclipse Installation Instructions on 
Annabooks.com to install the software needed for this hands-on exercise. 
 

1.1 Basic Nios II Project 

For this design, we will have a Nios II processor IP block, along with an onboard RAM IP Block, 
and a JTAG UART IP Block. The application will simply send messages out the JTAG interface to 
a console application running in Eclipse. There are two parts to the design process. The first 
involves creating the hardware design in Quartus Prime and Platform Builder. The second step is 
to create the application with Eclipse. 
 

1.1.1 Create the Project 
The first step is to create a design project. 
 

1. Open Quartus. 
2. Click on the New Project Wizard. 

 

http://www.annabooks.com/
https://www.annabooks.com/Articles/Articles_FPGA/Intel-FPGA-Tools-Setup-Rev1.1.pdf
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3. Click Next to the Introduction dialog. 
4. Select or create a project directory \NIOSii_Example (Do not use the Quartus installation 

directory) and name the project: “NIOS2CPU”. Click Next. 
 
Note: By default, the root directory is the Quartus installation directory. Make sure the root project 
directory is a separate path from the Quartus installation files. Also, there can be no spaces in the 
name of the folders or projects. 
 

5. Project Type: Empty project, click Next. 
6. Add File: no files to add, click Next. 
7. Family, Device & Board Settings: click the Board tab and select: MAX 10 FPGA 10M08 

Evaluation Kit. Click Next. 
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8. EDA Tools: click Next. 
9. Summary: click Finish 

 
Note: The actual MAX 10 on our board is the 10M08SAE144C8G, thus it is not an Engineering 
Sample (ES). The next two steps change the device to the production device. Your experience 
might be different. These next two optional steps change the device. 
 

10. In the project navigation pane on the left, right-click on 10: 10M08SAE144C8GE, and select 
Device from the context menu. 

11. In the Available devices, scroll down and select the 10M08SAE144C8G. Click OK. 
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1.1.2 Create the Design Step 1: Platform Designer 
Quartus supports many design types to create an FPGA design. The Platform Designer tool will be 
used for this hands-on exercise. Platform Builder makes it easy to add already-built IP blocks and 
interconnect them. 
 

1. From the menu, select Tools->Platform Designer, or the Platform Designer icon  
from the toolbar. 

 
The Platform Designer tool is launched. By default, a clock (clk_0) is added to the design. Platform 
Designer makes it easy to add IP blocks and make interconnections between the blocks. 
 

2. The top left pane contains the IP Catalog with all the available IP blocks that come with 
Quartus Prime. In the search box, type NIOS. 

 



 
Rev 1.4 

 

Copyright © 2022 Annabooks, LLC. All rights reserved 
Intel, Quartus, and MAX 10 are registered trademarks of Intel Corporation 
All other copyrighted, registered, and trademarked material remains the property of the respective owners. 

5 

 
 

3. Expand the Processors and Peripherals and the Embedded Processors branches. Under 
Embedded Processors double-click on the Nios II Processor. 

4. This will open the Nios II Configuration page. The first tab is used to select the type of core 
Nios II/e or Nios II/f. We will keep the Nios II/f default for this exercise. Click Finish. 
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5. Now let’s add the RAM IP block. In the IP Catalog enter RAM in the search box. 
6. Double-click on On-chip Memory (RAM or ROM) in the Intel FPGA IP.  
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7. The configuration page will appear. Change the Total memory size to 8192 and click Finish. 
 

 
 

8. In the IP Catalog search, enter uart. 
9. Double-click on the JTAG UART Intel FPGA IP. 
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10. A configuration page will appear. There are no changes to be made. Click Finish. 
11. In the IP Catalog search, enter the system ID. 
12. Double-click on the System ID Peripheral Intel FPGA IP. 
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13. A configuration page will appear. There are no changes to be made. Click Finish. 
14. Rename the IP blocks as follows: 

 

• nios2_gen2_cpu 

• onchip_RAM 

• jtag_uart 

• sysid 
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15. Now we need to wire the IP blocks together. First, wire all the clk lines together by clicking 
on the dots for all four IP blocks. 
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16. Next, connect all the reset lines together by clicking on the dots for all four IP blocks. 
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17. The memory lines have to be connected together. The s1 line in the RAM and 
Avalon_jtag_slave line in jtag_uart will be connected to the nios2_gen_cpu data_master 
and instruction master lines. Click on the dots for each IP block. 

18. Connect the sysid control_slave to nios2_gen_cpu data_master. 
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19. Finally, connect the jtaq_uart irq line to the nios2_gen2_cpu. 
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20.  If you scroll to the right, the irq is given a default value. 
 

 
 

21. Let’s assign a base address. From the menu, select System->Assign Base Address. This 
will remove a number of errors from the message box. 
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22. Finally, let’s set the reset and exception vector addresses.  Double-click on the 
nios2_gen2_cpu to open the configuration page. 

23. Click on the Vectors tab. 
24. Change the Reset vector memory drop-down to onchip_RAM.s1. 
25. Change the Exception vector memory drop-down to onchip_RAM.s1. 

 



 
Rev 1.4 

 

Copyright © 2022 Annabooks, LLC. All rights reserved 
Intel, Quartus, and MAX 10 are registered trademarks of Intel Corporation 
All other copyrighted, registered, and trademarked material remains the property of the respective owners. 

16 

 
 

26. Click on Generate HDL… 
27. Keep the defaults and click the Generate button. 
28. A dialog will appear asking you to save the design, click Save. 
29. Give the name as NIOS2.qsys and click Save. 
30. Once the save has been completed, click Close. 
31. The generate process kicks off. The processes should succeed, click Close. 
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32. Click Finish to close the design. 
33. Quartus then reminds you to add the new design to the project. Click Ok. 
34. In the Project Navigator, click on the drop-down and select Files. 
35. Right-Click on Files and select Add/Remote Files in Project. 

 

 
 

36. A Settings – NIOS2CPU page appears with Files on the left highlighted. Click the three 
dots, browse button for File name, and navigate to \NIOSii_Example\NIOS2\synthesis 
folder.  

37. Click on NIOS2.qip file and click open 
 

 
 

38. Click OK to close the Settings - NIOS2CPU page. The qip file is added to the Project 
navigator list. Underneath are all the Verilog files that were generated by Platform Builder. 
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1.1.3 Create the Design Step 2: Block Diagram 
With the qip file and all the Verilog files added to the project, let’s create the block diagram and 
complete the design. 
 

1. From the menu, select New->Block Diagram/Schematic File or the  icon from the 
toolbar. Click Ok. 

2. The symbol window appears. Double-click on the symbol window and the symbol dialog 
appears. 

3. Click on the 3 dots to open the file browser. 
4. Browse to \NIOSii_Example\NIOS2 folder and open the NIOS2.bsf file. 

 

 
 

5. The symbol for the NIOS2 appears. Click OK to add the symbol to the schematic. 
6. Drag the mouse with the NIOS2 symbol to a location on the diagram and then left-click to 

drop it in place. 
7. Right-click on the NIOS2 symbol and select Generate Pins for Symbol Ports. 
8. Change the name of the clk_clk pin to clk_50MHz. 
9. Change the name of the reset_reset_n to SW1. The SW1 switch on the evaluation kit is 

connected to the FPGA DEV_CLRN pin. The circuit for SW1 is logic 1 on startup and logic0 
when pressed. 

 



 
Rev 1.4 

 

Copyright © 2022 Annabooks, LLC. All rights reserved 
Intel, Quartus, and MAX 10 are registered trademarks of Intel Corporation 
All other copyrighted, registered, and trademarked material remains the property of the respective owners. 

19 

 
 

10. Save the schematic as NIOS2CPU.bdf. 
11. In the Task pane on the left, double-click on Fitter (Place & Route) to start the task. The 

analysis will take some time, and it should succeed in the end. This step helps to diagnose 
any errors and finds the Node Names for the pin assignments in the next step. 

 
12. Once the process completes, the pin assignments need to be set. From the menu select 

Assignments->Pin Planner or click on the  icon from the toolbar. The analysis that 
was just run populated the Node Name list at the bottom of the Pin Planner dialog. 

 

 
 

13. Using the board schematic, locate the pins for the SW1 and the 50Mhz clock. Set the 
Location values for both node names. For the MAX 10 – 10M08 Evaluation Board, these 
values are as follows: 

 

Node Name Location 

SW1 PIN_121 

Clk_50MHz:  PIN_27 

altera_reserved_tck PIN_18 

altera_reserved_tdi PIN_19 

altera_reserved_tdo PIN_20 

altera_reserved_tms PIN_16 

 
14. Set the I/O Standard to 3.3V-LVTTL for both pins. You can see from the schematic that all 

of the I/O are tied to 3.3V. 
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15. Close the Pin Planner when finished. The diagram gets updated with the pin numbers. 
 

 
 

16. Save the project. 
 
Note: A best practice at this point would be to make a backup of the project folder. Quartus can 
crash unexpectedly, since it appears to be written in Java. 
 

17. Finally, compile the design. In the Task pane, right-click on Compile and Design and select 

Start from the context menu, or you can click on the  symbol in the toolbar.  
 
When the compilation hits the Assembler task, an error will appear.  
 

 
 
Performing an Internet search reveals the solution on intel.com. It is a known problem for the Max 
10: Error (14703): Invalid internal configuration mode for design with... (intel.com) 
 

https://www.intel.com/content/www/us/en/support/programmable/articles/000074796.html
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From this page: 
 

Bug ID: FB: 466229; 
 
Description 
You may see this error while compiling a custom FIFO or a RAM block in Quartus® Prime 
software Standard / Lite version for a MAX® 10 device. 
 
This error is seen because MAX 10 Compact variants do not support memory initialization. 
If you have not provided any mif file for your custom design and still see this error in 
Quartus Prime software, it may be because a mif file is being inferred by the RTL coding 
style 
 
Resolution 
Signal declaration for memory_type should be changed from 
 
    signal mem : memory_type :=(others => (others => '0')); 
 
to 
 
    signal mem : memory_type; 
 
This is to ensure that memory is not initialized and there is no compilation error in the 
Assembler stage. 

 
The solution is dealing with the code, but there is a simple solution back in the onchip_RAM 
confirmation page. 
 

18.  Open Platform Builder and open the NIOS2.qsys file. 
19. After the design loads, double-click on the onchip_RAM to bring up the configuration page. 
20. Uncheck the “Initialize memory content”. 
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21. Click on Generate HDL… 
22. Click Close after the save process completes. 
23. Click Close after the generation completes. 
24. Click Finish to close Platform Builder. 
25. The Quartus reminder appears. Click Close. 
26. Compile the design again, and this time it should be successful. 
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1.1.4 Program the Board 
With the design compiled, we can now test the design on the board. 
 

1. Connect the board and the programming cable together per the cable instructions.  
 
Note: The MAX 10 – 10M08 Evaluation Kit doesn’t come with a programming cable or built-in JTAG 
USB Blaster II. You will have to use either the USB Blaster II or EthernetBlaster II external cables. 
The EthernetBlaster II was used. DHCP setup was not working, so a direct Ethernet cable 
connection was made between a PC and the EthernetBlaster II. Set the static IP for the PC network 
card to 198.162.0.1. Access the EthernetBlaster II via a browser and then change the IP to a static 
IP that matches the network. The new IP address was used as the Server name. Your experience 
might be different. 
 

2. Power on the board and the programming cable box. 
3. In Quartus Prime, from the Task pane, right-click on Program Device (Open Programmer) 

and select Open from the context menu or click on the  icon on the toolbar. 
4. The Programmer dialog appears, click on the “Hardware Setup” button. 
5. Click the Add hardware button, select the Hardware type, and fill in any remaining 

information, and click OK. 
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6. The tool allows you to connect to a number of programming cables. We need to select the 
one for our board. In the “Currently selected hardware”, click the drop-down, select the 
hardware cable for the board, and click Close when finished 

 

 
 

7. An NIOS2CPU_time_limited.sof file gets created during the Compile Design flow. The file 
is automatically filled in. There is only one FPGA on the board and in the JTAG chain so 
the file already has the Program/Configure checkbox checked. Click the Start button to 
program the board. The process takes a few seconds and shows that the task was 
completed successfully.  
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Note: The reason for the “time_limited” in the name of the .sof file is that we chose a Nios II/f, which 
requires a license. The design must be connected to the JTAG cable or the system will shut off 
after an hour. 
 

 
 
A dialog will appear that the design is time limited to one hour. The design can always be reloaded 
if the timeout occurs. 
 

 
 
Important: This dialog acts as a tether to the time-limited IP. You must leave this dialog running 
while you are running applications. 
 

1.1.5 Write and Deploy an Application in Eclipse 
Now, we are ready to create an application to run on the Nios II processor. 
 

1. In Quartus Prime, from the menu, select Tools->NIOS II Software Build Tools for Eclipse. 
2. Eclipse will open and ask for the root workspace directory. Set the workspace folder to 

something like \Documents\FPGA\Apps, and hit ok. It doesn’t matter the location of the 
workspace, since the actual applications for the project will exist within the 
\NIOSii_Example\software folder. 

3. In Eclipse, from the menu, select File->New-> Nios II Application and BSP from Template. 
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4. The first step is to open the SOPC file that was generated for the hardware design. Click 
on the three dots button. 

5. Navigate to the \NIOSii_Example folder and open the NIOS2.sopcinfo file. The CPU name 
will reflect the name we gave the CPU in Platform Builder. 

6. Enter the project name: simpleNIOS2AppSmall. 
7. In the Project Template, select Hello World Small. The Hello World Small template creates 

a small footprint application that uses the newlib C library and other footprint-reduced 
features. This is the ideal template to use when memory is tight. The calls made in the 
project are to the HAL-exposed APIs. 

8. Click Finish. 
 

 
 
Two projects will be generated. The simpleNIOS2AppSmall_bsp is generated to give you the HAL 
drivers and API based on the hardware design. The simpleNIOS2AppSmall is the application that 
will run on the hardware. 
 

9. Expand the simpleNIOS2AppSmall project. 
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10. Open the hello_world_small.c file. The code will look similar to a C application, but instead 
of a printf method, an alt_putstr method is called.  

 
#include "sys/alt_stdio.h" 
 
int main() 
{  
  alt_putstr("Hello from Nios II!\n"); 
 
  /* Event loop never exits. */ 
  while (1); 
 
  return 0; 
} 

 
The #include “sys/alt_stdio.h” is and include-file from the BSP project that contains the prototypes 
for standard IO calls. 
 
#include <stdarg.h> 
 
 
#ifdef __cplusplus 
extern “C” { 
#endif 
 
int alt_getchar(); 
int alt_putchar(int c); 
int alt_putstr(const char* str); 
void alt_printf(const char *fmt, …); 
#ifdef ALT_SEMIHOSTING 
int alt_putcharbuf(int c); 
int alt_putstrbuf(const char* str); 
int alt_putbufflush(); 
#endif 
#ifdef __cplusplus 
} 
#endif 

 
11. Add a newline character to output an additional string to the standard output. 

 
#include "sys/alt_stdio.h" 
 
int main() 
{  
  alt_putstr("Hello from Nios II!\n"); 
   alt_putstr("Programming is fun!"); 
  /* Event loop never exits. */ 
  while (1); 
 
  return 0; 
} 

 
12. Right-click on simpleNIOS2AppSmall project and select Build Project from the context 

menu. The build should complete successfully with a simpleNIOS2AppSmall.elf file being 
created. 
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13. With the JTAG cable connected and the hard design already programmed into the chip, 
right-click on simpleNIOS2AppSmall project and Run AS->NIOS II Hardware.  

 

 
 
The application will download and run. Since the JTAG is the standard output for the system, the 
Nios II Console will show the output from the JTAG UART. 
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Warning: The tools make it easy to download and run applications but multiple application 
download attempts can cause the tools to crash with a java runtime pop-up error. 
 

1.1.6 What if Hello World Template Is Used Instead? 
If the Hello World template was chosen instead of the Hello World small, the code for the application 
would look like the regular C hello world application that we all know. 
 
#include <stdio.h> 
 
int main() 
{ 
  printf("Hello from Nios II!\n"); 
 
  return 0; 
} 

 
When building the project, the compilation will result in an error that you have overflowed the RAM 
allocated for the hardware. The small template is better to use when memory is this limited. 
 

 
 
Keep in mind the 10M08 is a middle-range of the MAX 10 family. A part in the upper end of the 
family with more logic elements could handle the bigger libraries like stdio. The Intel® MAX® 10 - 
10M08 Evaluation Kit is a simple board that helps you get started with the basics of designing 
FPGAs. 
 

1.1.7 Debug the SimpleNIOS2AppSmall Application 
Debugging an application is simple. 
 

1. In the hello_world_small.c file, set a breakpoint at the first alt_putstr. 
2. With the JTAG cable connected and the hard design already programmed to the chip, right-

click on simpleNIOS2AppSmall project, Debug As->NIOS II Hardware.  
3. In Windows, a dialog will ask to unblock the application from running. Click Yes. 
4. Eclipse will pop a message asking to change to debug perspective. 
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5. The application will be downloaded and started running, and the breakpoint will be reached. 
You can now step through the application. 

 

1.2 Summary: Lots of Options to Choose From 

There are many design choices to consider. For example, the Nios II/e might have been a better 
solution for this example than the Nios II/f. A little experimentation is required to get a feel for the 
features. Hopefully, this walk-through of a Nios II design from the start to running a C application 
on the hardware was beneficial. 
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